Ergebnis 1 bis 7 von 7

Thema: Fehler 1709 bei der Installation.

  1. #1
    Benutzer
    Registriert seit
    29.04.2011
    Ort
    Stuttgart
    Alter
    39
    Beiträge
    51

    Fehler 1709 bei der Installation.

    Hallo zusammen,
    Ich bekomme in letzter Zeit öfters diese Fehlermeldung.

    Index column size too large. The maximum column size is 767 bytes.
    Ich versteh nur nicht das Problem.

    Ich benutze mysql 5.6.40
    bis vor kurzem PHP 5.6 habe jetzt auf 7.0 gestellt

    Ich habe versucht vb5 zu installieren erfolglos, heute habe ich vb3 versucht immer dieser Fehler 1709.
    In der DB fällt mir auf das der typ nun InnoDB ist war das nicht immer MyISAM hat sich hier was geändert?

    p.s ich habe nichts verstellt und hatte schon viele CMS Installiert noch nie probleme gehabt.

    MFG
    moby

  2. #2
    vBulletin-Germany Team Avatar von pogo
    Registriert seit
    01.06.2001
    Ort
    Hannover
    Alter
    43
    Beiträge
    16.384
    Blog-Einträge
    5
    Hast du die genaue Fehlermeldung?

    Kannst du oder der Hoster die MySQL Variable innodb_large_prefix auf On setzen?

    Mein Wunschzettel
    Warum du keine Anhänge herunterladen kannst!
    Suchst du Hacks, Add-ons, Modifikationen, Styles, Buttons und mehr? -> Auf zu vBGo!

  3. #3
    Benutzer
    Registriert seit
    29.04.2011
    Ort
    Stuttgart
    Alter
    39
    Beiträge
    51
    Nach der Variable habe ich geschaut sie ist auf on.

    PHP-Code:
    Datenbankfehler in vBulletin 

    Invalid SQL

    CREATE TABLE adminmessage 
    adminmessageid INT UNSIGNED NOT NULL AUTO_INCREMENT
    varname varchar(250NOT NULL DEFAULT ''
    dismissable SMALLINT UNSIGNED NOT NULL DEFAULT '0'
    script varchar(50NOT NULL DEFAULT ''
    execurl mediumtext
    method enum('get','post'NOT NULL DEFAULT 'post'
    dateline INT UNSIGNED NOT NULL DEFAULT '0'
    status enum('undone','done','dismissed'NOT NULL default 'undone'
    statususerid INT UNSIGNED NOT NULL DEFAULT '0'
    PRIMARY KEY (adminmessageid), 
    KEY script_action (scriptaction), 
    KEY varname (varname
    ); 

    MySQL-Fehler  Index column size too largeThe maximum column size is 767 bytes
    Fehler-Nr.    : 1709 
    Fehler
    -Zeit   Monday16.07.2018 23:31:52 
    Datum         
    Monday16.07.2018 23:31:52 
    Skript        
    http://phptest.visenet.info/install/install.php?do= 
    Referrer      http://phptest.visenet.info/install/install.php?step=3&emptydb=true 
    IP-Adresse    IPADDRESS 
    Benutzername  

    Klassenname   vB_Database_MySQLi 
    MySQL
    -Version 5.6.40-log 
    Server        

    Useragent     

    Stack Trace

    #0 vB_Database->halt() called in [path]/includes/class_core.php on line 1254 
    #1 vB_Database_MySQLi->execute_query() called in [path]/includes/class_core.php on line 450 
    #2 vB_Database->query_write() called in [path]/install/installcore.php on line 370 
    #3 exec_queries() called in [path]/install/install.php on line 272 
    hier noch ein Bild was in die db eingetragen wurden bis der abbruch kam.

    db.jpg

  4. #4
    vBulletin-Germany Team Avatar von pogo
    Registriert seit
    01.06.2001
    Ort
    Hannover
    Alter
    43
    Beiträge
    16.384
    Blog-Einträge
    5
    Ok. Dann gibt es folgende Möglichkeiten:

    - Wechsel zu MySQL 5.7.x
    - neue Datenbank mit dem Zeichensatz utf8 erstellen (aktuell ists ja utf8mb4)
    - alle Indizes mit varchar(250) [hier ists ja das Feld varname] in der mysql-schema.php in varchar(191) ändern, was natürlich ein wenig Aufwand sein wird

    Mein Wunschzettel
    Warum du keine Anhänge herunterladen kannst!
    Suchst du Hacks, Add-ons, Modifikationen, Styles, Buttons und mehr? -> Auf zu vBGo!

  5. #5
    Benutzer
    Registriert seit
    29.04.2011
    Ort
    Stuttgart
    Alter
    39
    Beiträge
    51
    Ich habe diesen Weg gewählt:
    - alle Indizes mit varchar(250) [hier ists ja das Feld varname] in der mysql-schema.php in varchar(191) ändern, was natürlich ein wenig Aufwand sein wird

    Hier der nächste Fehler:
    Code:
    Datenbankfehler in vBulletin :
    
    Invalid SQL:
    
    CREATE TABLE bbcode (
        bbcodeid SMALLINT UNSIGNED NOT NULL AUTO_INCREMENT,
        bbcodetag VARCHAR(200) NOT NULL DEFAULT '',
        bbcodereplacement MEDIUMTEXT,
        bbcodeexample VARCHAR(200) NOT NULL DEFAULT '',
        bbcodeexplanation MEDIUMTEXT,
        twoparams SMALLINT NOT NULL DEFAULT '0',
        title VARCHAR(100) NOT NULL DEFAULT '',
        buttonimage varchar(191) NOT NULL DEFAULT '',
        options INT UNSIGNED NOT NULL DEFAULT '1',
        PRIMARY KEY (bbcodeid),
        UNIQUE KEY uniquetag (bbcodetag, twoparams)
    );
    
    MySQL-Fehler  : Index column size too large. The maximum column size is 767 bytes.
    Fehler-Nr.    : 1709
    Fehler-Zeit   : Tuesday, 17.07.2018 @ 17:12:38
    Datum         : Tuesday, 17.07.2018 @ 17:12:38
    Skript        : http://phptest.visenet.info/install/install.php?step=3
    Referrer      : http://phptest.visenet.info/install/install.php?step=2
    IP-Adresse    : IPADDRESS
    Benutzername  : 
    Klassenname   : vB_Database_MySQLi
    MySQL-Version : 5.6.40-log
    Server        : 
    Useragent     :

  6. #6
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    57
    Beiträge
    13.378
    Der beste Weg in dem Fall ist vermutlich, auf MySQL 5.7 zu gehen, falls möglich.
    Ansonsten wirst Du Dir wahrscheinlich nur weitere Fehler generieren.

    Und unabhängig davon bitte auch sicherstellen, dass in der config.php des vBulletin in der Datenbank-Sektion "mysqli" statt "mysql" eingetragen ist. Das wird zwar wahrscheinlich schon der Fall sein, aber zur Sicherheit mal checken.
    Liebe Grüße
    Jörg


    Spezifische Fragen zum MySQLDumper bitte nicht hier, sondern im MSD-Support-Forum stellen.
    Aktuell verfügbare Version: MSD 1.24.4

    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  7. #7
    Benutzer
    Registriert seit
    29.04.2011
    Ort
    Stuttgart
    Alter
    39
    Beiträge
    51
    Ich habe es geschaft.

    Ich habe in der Datenbank diesen Befehl ausgeführt:
    ALTER DATABASE Datenbankname DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci

    obwohl ich das utf8mb4_general_ci in phpMyadmin nie geändert bekomme habe .

    utf8mb4.JPG

    Obwohl an einer andere stelle ich doch es geändert sehe , komisch alles

    utf8_general_ci.JPG

    Irgendwie hat der Befehl doch funktioniert.
    Am ende Habe ich noch den Varchar (250) und den Varchar(200) alle auf 191 gestellt

    Vielen Dank

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. CMS - Installation und Fehler
    Von T.P. im Forum vBulletin 4 Fragen und Probleme
    Antworten: 1
    Letzter Beitrag: 20.05.2012, 23:29
  2. Forum - Installation 4.1.1 Fehler
    Von Zera im Forum vBulletin 4 Installation und Upgrades
    Antworten: 12
    Letzter Beitrag: 27.02.2011, 13:14
  3. Fehler bei Installation
    Von Michael Million im Forum vBulletin-Blog Fragen und Probleme
    Antworten: 5
    Letzter Beitrag: 05.02.2009, 11:40
  4. Fehler bei Installation
    Von MichaelB im Forum vBulletin 3.5 Fragen und Probleme
    Antworten: 8
    Letzter Beitrag: 18.04.2006, 22:54
  5. Fehler bei Installation
    Von Fussi im Forum vBulletin 3.0 Fragen und Probleme
    Antworten: 11
    Letzter Beitrag: 15.08.2004, 16:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •