Ergebnis 1 bis 6 von 6

Thema: Updatet auf 4.2.5 nicht

  1. #1
    vB-Experte Avatar von MaxisSpieler
    Registriert seit
    08.11.2006
    Ort
    Bayern - Ingolstadt
    Alter
    26
    Beiträge
    768
    Blog-Einträge
    2

    Updatet auf 4.2.5 nicht

    Hallo
    Ich habe den Text wie im Forum angegeben geändert dann kommt diese meldung:

    Aufgrund der folgenden Fehler kann die Installation bzw. das Upgrade nicht fortgesetzt werden:
    • Die folgenden Dateien sind entweder nicht vorhanden oder fehlerhaft. Die häufigste Ursache dafür ist, dass nicht alle Dateien der vBulletin-Version fehlerfrei hochgeladen wurden. Bitte laden Sie die Dateien neu hoch und stellen Sie sicher, dass die alten Versionen der Dateien überschrieben wurden.
      /install/includes/class_upgrade_vbblog.php - wurde verändert oder nicht richtig hochgeladen.




    Unerwarteter Text:<?xml version="1.0" encoding="windows-1252"?>
    <br />
    <b>Warning</b>: mysqli_query(): (42000/1064): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')
    )
    WHERE ipid IS NULL' at line 6 in <b>/www/htdocs/w00b9d52/forum/includes/class_core.php</b> on line <b>1386</b><br />
    <?xml version="1.0" encoding="windows-1252"?>
    <errors>
    <error><=!=[=C=D=A=T=A=[<p>Datenbankfehler</p>

    Invalid SQL:

    SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
    FROM blog_text bt
    JOIN blog bl USING (blogid)
    LEFT JOIN ipdata ip ON (
    bt.ipaddress = ip.ipid AND bt.blogtextid = ip.contentid
    AND bt.userid = ip.userid AND ip.contenttypeid IN (,)
    )
    WHERE ipid IS NULL;

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')
    )
    WHERE ipid IS NULL' at line 6]=]=></error>
    <error_html><=!=[=C=D=A=T=A=[<p>Datenbankfehler in vBulletin 4.2.5</p>
    <p>Invalid SQL:

    SELECT bt.userid, bt.dateline, blogtextid, ipaddress, firstblogtextid
    FROM blog_text bt
    JOIN blog bl USING (blogid)
    LEFT JOIN ipdata ip ON (
    bt.ipaddress = ip.ipid AND bt.blogtextid = ip.contentid
    AND bt.userid = ip.userid AND ip.contenttypeid IN (,)
    )
    WHERE ipid IS NULL;<p>
    <p>
    <strong>MySQL-Fehler</strong> : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')
    )
    WHERE ipid IS NULL' at line 6<br />
    <strong>Fehler-Nr.</strong> : 1064<br />
    <strong>Fehler-Zeit</strong> : Sunday, 11.02.2018 @ 16:53:09<br />
    <strong>Datum</strong> : Sunday, 11.02.2018 @ 16:53:10<br />
    <strong>Skript</strong> : http://www.nahverkehr-ingolstadt.de/forum/install/upgrade.php<br />
    <strong>Referrer</strong> : http://www.nahverkehr-ingolstadt.de/forum/install/upgrade.php<br />
    <strong>Klassenname</strong> : vB_Database_MySQLi<br />
    <strong>MySQL-Version</strong> : 5.7.20-nmm1-log<br />
    </p>]=]=></error_html>
    </errors>



    Danach bricht der die Aktuon ab ... woran liegt das?
    Ich habe es aber geändert und hochgeladen.
    Grüße Markus (MaxisSpieler)

  2. #2
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    57
    Beiträge
    13.419
    1. Welche PHP Version läuft?

    2- Hast Du VOR dem Upgrade Blog und CMS aktiviert?

    3. Ansonsten lade mal diese class_upgrade_vbblog.php Datei und überschreibe damit die aus Deinem Paket.
    Gruß
    Jörg


    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  3. #3
    vB-Experte Avatar von MaxisSpieler
    Registriert seit
    08.11.2006
    Ort
    Bayern - Ingolstadt
    Alter
    26
    Beiträge
    768
    Blog-Einträge
    2
    1. 5.5.38

    2. Nein war aus.

    3. okay?
    Grüße Markus (MaxisSpieler)

  4. #4
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    57
    Beiträge
    13.419
    Zitat Zitat von MaxisSpieler Beitrag anzeigen
    1. 5.5.38

    2. Nein war aus.
    Na dann hast Du doch schon 2 Ursachen dafür.

    4.2.5 erfordert mindestens PHP 5.6.x und zusätzlich sollte das Blog-System beim Upgrade unbedingt eingeschaltet sein. Ansonsten kommt es (leider) zu Fehlern.
    Anschließend kannst Du es ja wieder deaktivieren.
    Gruß
    Jörg


    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  5. #5
    vB-Experte Avatar von MaxisSpieler
    Registriert seit
    08.11.2006
    Ort
    Bayern - Ingolstadt
    Alter
    26
    Beiträge
    768
    Blog-Einträge
    2
    Ja geht wieder alles danke...
    wurde geupdatet.

    Ich hätte noch ein Problem zZ melden sich sehr viele Spambots bei mir an ... wie kann man das eindämmen? Mein Serveranbieter hat schon gesagt ich sollte was dagegen unternehmen ...
    Grüße Markus (MaxisSpieler)

  6. #6
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    57
    Beiträge
    13.419
    Zitat Zitat von MaxisSpieler Beitrag anzeigen

    Ich hätte noch ein Problem zZ melden sich sehr viele Spambots bei mir an ... wie kann man das eindämmen?
    Dazu erstelle am besten einen eigenen Thread, das hat ja mit dem anderen Thema nichts zu tun.
    Oder noch besser, suche hier mal nach den unzähligen Threads zu "Spambots", "Spam" usw.
    Da gibt es reichlich empfohlene Maßnahmen, von "Frage & Antwort" angefangen bis hin zu diversen Sperren und Fremddiensten. Das alles immer wieder neu zu schreiben, ist ziemlich müßig und anstrengend.
    Gruß
    Jörg


    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. Benutzerprofil nicht freigeschalteter User für Nicht-Admins nicht aufrufbar
    Von Gina im Forum vBulletin 3.8 Fragen und Probleme
    Antworten: 1
    Letzter Beitrag: 15.02.2010, 21:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •