Das in vBulletin 3.x und 4.x genutzte reCAPTCHA v1 wird am 31.3.2018 eingestellt.
Folglich wird es danach nicht mehr funktionieren.

Es gibt keine Pläne reCAPTCHA v2 in vBulletin 3.x oder 4.x zu integrieren.


Folgende (sinnvolle) Möglichkeiten stehen dann zur Verfügung:
1. Umstieg auf das Frage-Antwort-System von vBulletin
2. Installation eines reCAPTCHA v2 Add-ons eines Drittanbieters


Zwei Add-ons stehen bei vbulletin.org zur Verfügung:
vB 4.x: https://www.vbulletin.org/forum/showthread.php?t=315960
vB 3.x: https://www.vbulletin.org/forum/showthread.php?t=315964

Man muss aber das gesamte Thema lesen, um Fehlerbehebungen zu erhalten, die für den Einsatz mit der neuesten Version von vBulletin und neuen PHP-Versionen (PHP 7+) notwendig sind.