Ergebnis 1 bis 10 von 10

Thema: Error Number : 1146 - vbdatastore' doesn't exist - v 3-8-11

  1. #1
    Neuer Benutzer
    Registriert seit
    31.01.2007
    Beiträge
    20

    Error Number : 1146 - vbdatastore' doesn't exist - v 3-8-11

    Hallo zusammen,

    ich habe den Hoster gewechselt und hab prompt ein Fehler bei der Installation.

    Die Installation lief soweit problemlos ab, aber ich hab eine vBulletin Database Error! erhalten :

    MySQL Error : Table 'usr_xyz.vbdatastore' doesn't exist
    Error Number : 1146


    Bei der Installation konnte ich aber folgendes feststellen :

    Creating vbdatastore table
    Inserting default data into vbdatastore
    Geändert von oliveer (17.08.2017 um 20:37 Uhr) Grund: Lösung gefunden ;)

  2. #2
    vBulletin-Germany Team Avatar von pogo
    Registriert seit
    01.06.2001
    Ort
    Hannover
    Alter
    42
    Beiträge
    16.305
    Blog-Einträge
    5
    Du hast also den Hoster gewechselt und willst dort ein komplett neues Forum aufbauen. Das alte soll nicht importiert werden oder so?

    Oder was genau hast du vor?

    Mein Wunschzettel
    Warum du keine Anhänge herunterladen kannst!
    Suchst du Hacks, Add-ons, Modifikationen, Styles, Buttons und mehr? -> Auf zu vBGo!

  3. #3
    Neuer Benutzer
    Registriert seit
    31.01.2007
    Beiträge
    20
    Erst einmal möchte ich das Forum neu installieren und dann später das Backup meines alten Forums einspielen, aber soweit komme ich nicht, da ich ja die Fehlermeldung erhalte.

    Also bisher nur die jungfräuliche Installation ...

  4. #4
    vBulletin-Germany Team Avatar von pogo
    Registriert seit
    01.06.2001
    Ort
    Hannover
    Alter
    42
    Beiträge
    16.305
    Blog-Einträge
    5
    So funktioniert das nicht.

    Du musst nur das Backup einspielen.
    Also Dateien kopieren und Datenbank-Backup einspielen.

    Mein Wunschzettel
    Warum du keine Anhänge herunterladen kannst!
    Suchst du Hacks, Add-ons, Modifikationen, Styles, Buttons und mehr? -> Auf zu vBGo!

  5. #5
    Neuer Benutzer
    Registriert seit
    31.01.2007
    Beiträge
    20
    Seltsam .... Aber bei einer jungfräulichen Installation darf es doch keine Fehler werfen .... Bei meinem alten Hoster hat es geklappt

  6. #6
    vBulletin-Germany Team Avatar von pogo
    Registriert seit
    01.06.2001
    Ort
    Hannover
    Alter
    42
    Beiträge
    16.305
    Blog-Einträge
    5
    Darf nicht. Ich kann mir auch nur vorstellen, dass in der config.php ein anderes Präfix für die Datenbank Tabellen angegeben ist, als in der Datenbank tatsächlich genutzt wird.

    Mein Wunschzettel
    Warum du keine Anhänge herunterladen kannst!
    Suchst du Hacks, Add-ons, Modifikationen, Styles, Buttons und mehr? -> Auf zu vBGo!

  7. #7
    Neuer Benutzer
    Registriert seit
    31.01.2007
    Beiträge
    20
    Das hast du irgendwie falsch verstanden .... Download der Datei von vbulletin.com, Änderung der config.php und upload und dann ganz normal den Installer gestartet ....

  8. #8
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    56
    Beiträge
    13.197
    Was Du beschreibst als Vorgang, ist schon verständlich (auch wenn ich den Sinn nicht ganz verstehe, wenn Du bereits ein Forum hattest und das später wieder nutzen möchtest).
    Nur macht Dein erster Beitrag dann keinen Sinn, denn bei einer Erst-Installation exisitiert (natürlich) noch überhaupt kein vBulletin Datastore. Die Meldung ist also berechtigt - nur ebenso unsinnig, sie auszugeben. Denn die Tabelle wird natürlich erst noch angelgt, kann also auch nicht bereits existieren.

    Derartige Meldungen kommen eigentlich nur dann, wenn eine Software bereits versucht auf eine bestimmte Tabelle zuzugreifen (die vorhanden sein sollte), diese aber samt Präfix so nicht existiert. Und DEIN Präfix kommt ja definitiv nicht von vBulletin. Läuft da evtl. doch schon ein Add-on im Hintergrund oder hast DU dieses Präfix angegeben?

    Es klingt also nicht nach einem "Installationsvorgang", sondern eher nach einer bereits bestehen Datenbank, bei der Du gerade irgendetwas anderes (als eine Erstinstallation) versuchst.
    Also knall die komplette Datenbank jetzt erstmal weg, lege beim Hoster eine neue an und trage deren Zugangsdaten in die config.php ein. DANN starte den Installationsprozess (sollte eine install.php sein). Dann klappt es normal auch ohne Fehlermeldungen.
    Liebe Grüße
    Jörg


    Spezifische Fragen zum MySQLDumper bitte nicht hier, sondern im MSD-Support-Forum stellen.
    Aktuell verfügbare Version: MSD 1.24.4

    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  9. #9
    Neuer Benutzer
    Registriert seit
    31.01.2007
    Beiträge
    20
    Irgendwie blick ich jetzt garnicht mehr durch ... Ich hab es endlich geschafft, aber irgendwie ist die Lösung sehr dubios.

    Download der Datei vbulletin 3.8.11 von vbulletin.com, entpackt und die Daten von der neu erstellten Datenbank entsprechend eingetragen ...


    • Step 3 Creating datastore table
    • Step 5 Inserting default data into datastore


    Installation lief problemlos durch, nur am Ende kam dann die eMail mit der Fehlermeldung

    Database error in vBulletin :

    Invalid SQL:

    SELECT *
    FROM datastore
    WHERE title IN ('','options','bitfields','attachmentcache','forumcache','usergroupcache','stylecache','languagecache','products','pluginlist','cron','profilefield',' loadcache','noticecache','userstats','birthdaycache','maxloggedin','iconcache','eventcache','mailqueue');

    MySQL Error : Table 'usr_xyz.datastore' doesn't exist
    Error Number : 1146

    Installation mit Mozilla und Microsoft Edge immer wieder das gleich Problem - einfach mal testweise mit dem Chrome installiert und siehe da, es hat funktioniert ...

    Der einzige Unterschied lag bei der automatisch eingetragenen Forum URL
    http://domain.de:443/forum (Firefox / Edge) und http://domain.de/forum (Chrome)

  10. #10
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    56
    Beiträge
    13.197
    Zitat Zitat von oliveer Beitrag anzeigen
    Ich hab es endlich geschafft, aber irgendwie ist die Lösung sehr dubios.

    [...]
    Der einzige Unterschied lag bei der automatisch eingetragenen Forum URL
    http://domain.de:443/forum (Firefox / Edge) und http://domain.de/forum (Chrome)
    Möglicherweise erzeugte aber genau das von mir im Zitat Fett-Markierte das Problem: Dein Link enthält eine Portnummer (was soweit nichts Ungewöhnliches ist) und Port 443 ist für SSL/TLS (also HTTPS) zuständig.
    Im URL hast Du da aber "nur" HTTP stehen.

    Vielleicht kam es da zu Konflikten? Der Port wird ja dann praktisch "erzwungen". Und ohne Zertifikat (auf dem entspr. Server) funktioniert das dann sowieso nicht.
    Im 2. Beispiel (Chrome) hattest Du es dann korrekt und das würde auch erklären, warum es damit dann "komischerweise" ohne Fehler lief.
    Liebe Grüße
    Jörg


    Spezifische Fragen zum MySQLDumper bitte nicht hier, sondern im MSD-Support-Forum stellen.
    Aktuell verfügbare Version: MSD 1.24.4

    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. Forum - vbseo sitemap gibt Fehler aus - Table 'db226280002.tagthread' doesn't exist
    Von Testworker im Forum vBulletin 4 Fragen und Probleme
    Antworten: 6
    Letzter Beitrag: 24.02.2012, 08:01
  2. Forum - MySQL-Fehler : Table 'xxxxxxxxxxx_forum.searchcore' doesn't exist
    Von lapo im Forum vBulletin 4 Fragen und Probleme
    Antworten: 1
    Letzter Beitrag: 07.08.2010, 12:03
  3. Table 'db291686277.EXTENDED' doesn't exist
    Von qix100 im Forum MySQL
    Antworten: 10
    Letzter Beitrag: 02.02.2010, 07:24
  4. 3.7.2 (PL.2) zu 3.8.2 - Fehler: profileblockprivacy' doesn't exist
    Von james_55 im Forum vBulletin 3.8 Installation und Upgrades
    Antworten: 2
    Letzter Beitrag: 24.05.2009, 19:22
  5. Upgrade.php: Error Number : 1146
    Von MichaelB im Forum vBulletin 3.6 Fragen und Probleme
    Antworten: 3
    Letzter Beitrag: 27.07.2006, 10:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •