Ergebnis 1 bis 10 von 10

Thema: Gast kann CMS nicht betreten .....

  1. #1
    Fortgeschrittener Benutzer Avatar von [rbc]
    Registriert seit
    05.06.2007
    Ort
    Schweiz
    Beiträge
    165
    Blog-Einträge
    1

    Frage Gast kann CMS nicht betreten .....

    Hallo Experten

    Anscheinend übersehe ich gerade etwas oder ich sehe den Wald vor lauter Bäumen nicht mehr.

    Schritt 1:
    Webspace -> neuen Ordner vB4TEST
    Schritt 2:
    Webspace -> neue leere Datenbank. (vB4TEST)
    Schritt 3:
    vB Kundenbereich (hier) PaketSuite runter geladen.
    Schritt 4:
    Paket entpackt und auf Webspace hochgeladen -> vB4TEST


    • Installiert (frische saubere NEU-Installation)


    AdminCP einen Testbenutzer erstellt (Registrierte Benutzer)
    Benutzergruppen verwalten -> die Rechte angepasst.
    Foren-Rechte: Suchfunktions-Rechte: Beitrags/Themen Rechte: (So wie immer)
    CMS Rechte angepasst:
    Wirklich einzeln explizit jede Gruppe zu jedem Bereich durchgegangen und jedes mal gespeichert.

    Das Problem:
    Der von mir angelegte Testbenutzer erhält auf der Startseite (CMS) die Meldung: (kennen wir alle)

    Systemmitteilung
    Sie sind nicht angemeldet oder sie haben keine Rechte diese Seite zu betreten. Dies könnte
    einer der Gründe sein: u.s.w. .........

    Nun gute denkt man da, dann habe ich eine Einstellung im CMS -> Rechte wohl übersehen.

    Ich Admin ins AdminCP und die Einstellungen überprüft. Nochmals wie oben beschrieben.
    Cache geleert abgemeldet neu angemeldet. Andere Browser versucht, nichts hilft.
    Was aber ganz erstaunlich ist, auch ich als Admin hatte keinen Zugriff auf die Startseite.
    Forum, Blog, Aktivitäten kein Problem, für mich und den Testbenutzer nicht, klappt einwandfrei
    Auch Gäste sollten im CMS lesen können. Keine Chance!

    Mit der Tools.php konnte ich die Rechte für mich Admin reparieren, jedoch ist das für einen normalen
    Registrierten Benutzer oder Gast ja nicht machbar. Ich konnte also letztendlich auch auf die Starseite
    wie es sich gehört.

    Das mit den Gästen und dem registrierten Benutzer habe ich nicht hingekriegt.
    --------------------------

    Datenbank gelöscht und auch den Webordner. (vB4TEST)
    Nochmals alles neu hochgeladen und installiert, danach konfiguriert und exakt dasselbe Ergebniss.

    Gäste und auch registrierte Benutzer, auch Moderatoren oder super Moderatoren bekommen einfach
    keinen Zugriff aufs CMS (Startseite). Forum und Blog sind kein Problem.

    Frage:
    Was übersehe ich?

    Ich habe nicht das erste mal mit vBulletin zu tun, kenne mich relativ gut aus, jedoch im Moment
    stehen zu viele Bäume im Wald.

    Es ist Anzumerken: vB4 und ich, werden langsam Freunde - Warum ? = Darum - print_output($templater->render());

  2. #2
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    56
    Beiträge
    13.166
    Die üblichen Verdächtigen:

    Pfad zum CMS korrekt?
    Cookie-Pfad/Domain?
    Falscher .htaccess Eintrag?
    Eigene CMS-Rechte richtig?
    Beiträge sind auch wirklich freigeschaltet/öffentlich?
    Sonst siehst Du sie zwar als Admin, aber niemand anderes.
    Liebe Grüße
    Jörg


    Spezifische Fragen zum MySQLDumper bitte nicht hier, sondern im MSD-Support-Forum stellen.
    Aktuell verfügbare Version: MSD 1.24.4

    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  3. #3
    Fortgeschrittener Benutzer Avatar von [rbc]
    Registriert seit
    05.06.2007
    Ort
    Schweiz
    Beiträge
    165
    Blog-Einträge
    1

    Pfeil

    Zitat Zitat von Jaydee Beitrag anzeigen
    Die üblichen Verdächtigen:

    Pfad zum CMS korrekt?
    Cookie-Pfad/Domain?
    Falscher .htaccess Eintrag?
    Eigene CMS-Rechte richtig?
    Beiträge sind auch wirklich freigeschaltet/öffentlich?
    Sonst siehst Du sie zwar als Admin, aber niemand anderes.


    Hallo Jaydee ist lange her ......
    Wie geht es denn so?

    Pfad zum CMS: URL der vBulletin-installation -> https://www.compusoft.li/vb4TEST
    (URL der vBulletin-Installation immer als Basis-URL verwenden) "Nein"
    URL des Forums, CMS, Blog: "leer".

    Pfad, der in Cookies gespeichert wird: "/vb4TEST/"
    Benutzerdefinierte Einstellung: "leer"

    .htaccess benutze ich nicht. (Bei vb5 ist die ja unerlässlich)

    Beiträge sind Veröffentlicht + Vorschau ohne Leseberechtigung.
    Auch im FrontEnd sind alle Artikel "Veröffentlicht"

    artikel.JPG cms-startseite.JPG cms-bereiche.JPG
    -------------------------------------------------------------------------------------------

    Jetzt kommt es ---------->

    Wenn ich die Rechte nun für Gäste auf "Kann veröffentlichen" stelle klappt alles wie es sein soll. Dasselbe gilt für alle anderen bei denen es sonst auch nicht funktioniert. (registered, mod, supMod)

    can-publish.jpg

    Natürlich wird aber glücklicherweise die Dropdown Liste Erstellen: (Artikel, Dynamische Php-Seite, Statische Html-Seite) nicht angezeigt.

    Bei mir Admin, mit allen Rechten klappt immer alles.

    Natürlich stimmen auch meine anderen Einstellungen Rechte Foren /cms !

    Foren-Rechte-Gast.JPG

    Das ist es was mich verwirrt. Alle Einstellungen sind korrekt. Beim Admin, alle Rechte, klappt alles. Alle anderen haben Probleme <-- betrifft nur das CMS (Startseite).

    Kennst du evtl. diese Symptome Jaydee ?

    schönen Gruss und danke

    Peter

    Es ist Anzumerken: vB4 und ich, werden langsam Freunde - Warum ? = Darum - print_output($templater->render());

  4. #4
    Fortgeschrittener Benutzer Avatar von [rbc]
    Registriert seit
    05.06.2007
    Ort
    Schweiz
    Beiträge
    165
    Blog-Einträge
    1

    Ausrufezeichen

    Zitat Zitat von [rbc] Beitrag anzeigen
    Wenn ich die Rechte nun für Gäste auf "Kann veröffentlichen" stelle klappt alles wie es sein soll. Dasselbe gilt für alle anderen bei denen es sonst auch nicht funktioniert. (registered, mod, supMod)
    Ich muss hier eine Korrektur vornehmen, denn dies stimmt so nicht ganz.

    Es muss "Kann lesen" + "Kann veröffentlichen" markiert sein. (siehe Bild unten)

    Ab dieser Einstellung, klappt das CMS wie es sein sollte.
    Für alle Benutzergruppen. Ausgenommen sind Admins, jedoch haben diese ja eh nahezu alle Rechte. (Und bei denen klappt es ja)

    cms-rechte-zuweisen.png

    Danke

    Es ist Anzumerken: vB4 und ich, werden langsam Freunde - Warum ? = Darum - print_output($templater->render());

  5. #5
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    56
    Beiträge
    13.166
    Zitat Zitat von [rbc] Beitrag anzeigen

    Hallo Jaydee ist lange her ......
    Wie geht es denn so?
    Hallo Peter,

    frag mich heute lieber nicht bei 33° C im Schatten! Ich sterbe hier so langsam vor mich hin...
    Das ist mit Abstand der heißeste Burzeltach meines Lebens...

    Also der Effekt ist mir bisher so nicht bekannt. Ein Recht zur Veröffentlichung musst nicht sein, Leserechte reichen aus.

    Was Du noch ändern könntest: Den Punkt "URL der vBulletin-Installation immer als Basis-URL verwenden" mal besser auf "Ja" stellen, oder alternativ wirklich für das CMS die/den (korrekte/n) URL hinterlegen.
    Was aber trotzdem noch nicht (logisch) erklären würde, warum es als Admin trotzdem geht...

    Dann fallen mir noch die Bereiche auf: Hast Du wirklich die Rechte für den RICHTIGEN Bereich gesetzt, in dem auch veröffentlicht wurde? Da sind ja mehrere "gesperrte", also mit Schloss-Symbol, zu sehen.
    Nicht dass da auf eine leere "CMS-Startseite" verwiesen wird.
    DIese kannst Du übrigens in den Einstellungen unter Homepage auch manuell festlegen, Default ist dort "1-Index".
    Das könntest Du auch mal prüfen.

    Ansonsten ist das Verhalten aber schon recht seltsam, wenn die Rechte alle passen.
    Liebe Grüße
    Jörg


    Spezifische Fragen zum MySQLDumper bitte nicht hier, sondern im MSD-Support-Forum stellen.
    Aktuell verfügbare Version: MSD 1.24.4

    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  6. #6
    Fortgeschrittener Benutzer Avatar von [rbc]
    Registriert seit
    05.06.2007
    Ort
    Schweiz
    Beiträge
    165
    Blog-Einträge
    1

    Pfeil

    Zitat Zitat von Jaydee Beitrag anzeigen
    Hallo Peter,
    frag mich heute lieber nicht bei 33° C im Schatten! Ich sterbe hier so langsam vor mich hin...
    Das ist mit Abstand der heißeste Burzeltach meines Lebens...
    Das ist bitter und der Sommer hat noch nicht einmal gebonnen

    Hallo Jörg

    Danke für alle deine Vorschläge.

    Was Du noch ändern könntest: Den Punkt "URL der vBulletin-Installation immer als Basis-URL verwenden" mal besser auf "Ja" stellen, oder alternativ wirklich für das CMS die/den (korrekte/n) URL hinterlegen.
    Den habe ich so eingestellt weil das Live-Forum in der Domain compusoft.li liegt und sowohl mit http als auch mit https zu erreichen ist.
    Habe ich aber schon vorher und jetzt nochmals getestet. Auch mit gesamt Pfad.
    Leider stellten sich keine Änderungen ein und ich habe es wieder auf (für mich) Standard zurück gesetzt.

    Dann fallen mir noch die Bereiche auf: Hast Du wirklich die Rechte für den RICHTIGEN Bereich gesetzt, in dem auch veröffentlicht wurde? Da sind ja mehrere "gesperrte", also mit Schloss-Symbol, zu sehen.
    Nicht dass da auf eine leere "CMS-Startseite" verwiesen wird.
    Diese kannst Du übrigens in den Einstellungen unter Homepage auch manuell festlegen, Default ist dort "1-Index".
    Das könntest Du auch mal prüfen.
    Da bin ich mir ganz sicher, habe dies auch 50 mal nachgeschaut und kontrolliert.
    Eine geschlossene Schlossgrafik wird immer angezeit, ab dem Moment wo ich ein Recht zuweise
    und auf "CMS-Rechte speichern" klicke. Ich kenne dies nicht anders. Habe aber nochmals alle CMS Rechte für alle
    Bereiche zurückgesetzt, dann werden geöffnete Schlossgrafiken angezeigt, jedoch habe ich dann auch als Admin keine
    Rechte mehr, die Startseite (CMS) anzuzeigen. Wird dann natürlich logischerweise allen verwehrt.

    Gebe ich dann dem Admin das Recht auf der Startseite lesen zu dürfen (und klicke auf) "CMS-Rechte speichern" ändert sich sofort
    die geöffnete Schlossgrafik in eine geschlossene Schlossgrafik aber ich der Admin kann die CMS Startseite wieder sehen.

    Mache ich dasselbe für den "Nicht registriert / Nicht angemeldet" Benutzer passiert nichts. Ich meine dieser sieht dann die Startseite (CMS) noch immer nicht. Gebe ich dem "Nicht registriert / Nicht angemeldet" Benutzer zusätzlich die Rechte "Kann veröffentlichen" sieht dieser ab sofort das CMS. (Startseite) Wie oben als Problem geschrieben.

    Das CMS (Startseite) ist mit content befüllt (Artikel)

    -
    Mein live Board läuft einwandfrei mit den Standardeinstellungen vBulletin-CMS: Allgemeines "1-Index" "content.php"
    -

    Also es ist Sonnenklar etwas ist definitv krumm. Aber es ist schon die zweite blanke Neuinstallation und es treten schon genau das zweite mal genau die selben Symptome auf. Das verwirrt mich.

    Schönen Tag für dich Jörg.

    Gruss, Peter

    Es ist Anzumerken: vB4 und ich, werden langsam Freunde - Warum ? = Darum - print_output($templater->render());

  7. #7
    Fortgeschrittener Benutzer Avatar von [rbc]
    Registriert seit
    05.06.2007
    Ort
    Schweiz
    Beiträge
    165
    Blog-Einträge
    1

    Daumen hoch

    Hallo Jörg

    Das Kopfzerbrechen hat ein Ende.
    Ich habe den Webordner und die DB nochmals platt gemacht.

    vB 4-2-5 von eurem Kundenbereich runter geladen und installiert.

    Erst mit deaktivierter charset Einstellung in der config.php
    PHP-Code:
    // $config['Mysqli']['charset'] = 'utf8'; 

    Alle Phrasen waren ab den Umlauten (äöü) nicht mehr zu lesen. (abgeschnitten)

    Dann mit aktivierter utf-8 Einstellung.
    PHP-Code:
    $config['Mysqli']['charset'] = 'utf8'
    Alle Phrasen waren ab den Umlauten (äöü) nicht mehr zu lesen. (abgeschnitten)

    Dann mit aktivierter latin1 Einstellung.
    PHP-Code:
    $config['Mysqli']['charset'] = 'latin1'
    Alles wie es sein soll. Auch mit den CMS Rechten stimmt nun alles. Habe wohl 2 x Pech gehabt


    Danke nochmals für deine Bemühungen.


    Wir sehen uns bestimmt wieder .....

    Alles Gute


    Gruss, Peter




    Es ist Anzumerken: vB4 und ich, werden langsam Freunde - Warum ? = Darum - print_output($templater->render());

  8. #8
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    56
    Beiträge
    13.166
    Hallo Peter,

    das freut mich.

    Ok, der Zeichensatz sollte natürlich auch bei der Datenbank passen und der Effekt des "Abschneidens" ist bekannt - aber in Verbindung mit Deinem CMS-Problem wäre ich da jetzt auch im Leben nicht drauf gekommen.

    Dann Dir auch einen entspannten Abend, ich schicke mal etwas Sonne (mit immer noch 31 Grad *ächz*) Richtung Schweiz.
    Liebe Grüße
    Jörg


    Spezifische Fragen zum MySQLDumper bitte nicht hier, sondern im MSD-Support-Forum stellen.
    Aktuell verfügbare Version: MSD 1.24.4

    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



  9. #9
    Fortgeschrittener Benutzer Avatar von [rbc]
    Registriert seit
    05.06.2007
    Ort
    Schweiz
    Beiträge
    165
    Blog-Einträge
    1

    Daumen hoch

    Zitat Zitat von Jaydee Beitrag anzeigen
    Hallo Peter,
    das freut mich.
    Ok, der Zeichensatz sollte natürlich auch bei der Datenbank passen und der Effekt des "Abschneidens" ist bekannt - aber in Verbindung mit Deinem CMS-Problem wäre ich da jetzt auch im Leben nicht drauf gekommen.
    Hallo Jörg

    Da habe ich mich wohl nicht ganz klar ausgedrückt (Ist wohl auch bei uns zu heiss )

    Das Problem war bestimmt nicht der Zeichensatz - CMS-Problem !
    Irgend etwas war da ganz seltsam - und konnte nicht gelöst werden, darum das ERNEUTE löschen !!

    Zitat Zitat von Jaydee Beitrag anzeigen
    Dann Dir auch einen entspannten Abend, ich schicke mal etwas Sonne (mit immer noch 31 Grad *ächz*) Richtung Schweiz.
    Deine "Sendung" ist angekommen Ich schicke dir 10° davon umgehend zurück!

    Herzlichen Dank nochmals für deine Bemühungen und eine angenehme Temperatur für dich.

    mfg

    Peter

    Es ist Anzumerken: vB4 und ich, werden langsam Freunde - Warum ? = Darum - print_output($templater->render());

  10. #10
    vB-Guru Avatar von Jaydee
    Registriert seit
    29.05.2008
    Ort
    ...tief im Westen....
    Alter
    56
    Beiträge
    13.166
    Achso, verstehe. Das hatte ich dann tatsächlich falsch interpretiert und hätte mich auch ziemlich gewundert.

    Joa, heute ist 1 Tag Pause mit "entspannten 25°" und innen 26. (25 sind genau richtig für mich im Sommer, mehr brauchts nicht)
    Ab Freitag solls ja wieder heißer werden...
    Liebe Grüße
    Jörg


    Spezifische Fragen zum MySQLDumper bitte nicht hier, sondern im MSD-Support-Forum stellen.
    Aktuell verfügbare Version: MSD 1.24.4

    Die deutsche Rechtschreibung ist Freeware. Das heißt, Du kannst sie kostenlos nutzen.
    Allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.



Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. AdminCP kann ich nicht betreten
    Von fenris im Forum vBulletin 3.8 Installation und Upgrades
    Antworten: 4
    Letzter Beitrag: 31.05.2013, 13:43
  2. Forum - Gast erscheint als online in einem Forum, das er gar nicht sehen kann
    Von nocte im Forum vBulletin 4 Fragen und Probleme
    Antworten: 4
    Letzter Beitrag: 20.11.2010, 02:36
  3. Gast kann Archivbeiträge in einem nicht öffentlichen Forum lesen?
    Von Vierie im Forum vBulletin 3.0 Fragen und Probleme
    Antworten: 3
    Letzter Beitrag: 04.06.2005, 20:07
  4. Forum mit Link kann jeder betreten.
    Von MaGuS im Forum vBulletin 3.0 Fragen und Probleme
    Antworten: 6
    Letzter Beitrag: 12.01.2004, 11:27
  5. Gast kann
    Von vdi im Forum vBulletin 2 Fragen und Probleme
    Antworten: 1
    Letzter Beitrag: 30.12.2003, 11:25

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •