Aktivitäten

Aktivitäten filtern
Sortieren nach Zeit Anzeigen
Aktualität Aktualität Beliebtheit Beliebtheit Alle Alle Letzte 24 Stunden Letzte 24 Stunden Letzte Woche Letzte Woche Letzter Monat Letzter Monat Alle Alle Bilder Bilder Forum Foren Artikel Artikel Blog Blogs Gruppen Gruppen
  • Avatar von wilhelm
    08.03.2019, 21:43
    Danke Jörg. War anscheinend blind. Schönes Wochenende.
    2 Antwort(en) | 993 mal aufgerufen
  • Avatar von Jaydee
    08.03.2019, 20:59
    ACP -> Anhänge -> Anhang Speicherart Am besten gibst Du dort einen relativen Pfad an, keinen absoluten. Dann passiert das auch zukünftig nicht mehr. Die config.php hat damit auch nichts zu tun.
    2 Antwort(en) | 993 mal aufgerufen
  • Avatar von wilhelm
    08.03.2019, 20:44
    Unser Forum musste beim Provider den Server wechseln. Folgendes Problem: Vorher lag das Forum im Order "web". Jetzt ist das nicht mehr so, es liegt jetzt im root. Das Forum läuft, nur die Anhänge sind nicht mehr erreichbar. Werden neue Anhänge erstellt, hat die Software einen Ordner erstellt: web/images/anhaenge. Hier speichert die Software nun alle neuen Anhänge. Wo kann ich die Einstellung ändern, dass wieder auf images/anhaenge ohne web vorweg zugegriffen wird? In der Config.php...
    2 Antwort(en) | 993 mal aufgerufen
  • Avatar von Boothby
    06.03.2019, 20:00
    Prüfe mal bitte, ob du überhaupt die richtigen Dateien bearbeitet hast. Es kann schon mal vorkommen, dass man die falsche erwischt. Da du einen eigenen Server hast und wenn shell_exec erlaubt ist, dann könnte folgendes Script helfen. <?php $commands = ; foreach($commands as $command) {
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von Jaydee
    05.03.2019, 22:15
    Das ist leider bei Add-ons nicht der Fall. Da Du sie "manuell" (per FTP) hochgeladen und dann erst das eigentliche Add.on (Plugins) importiert hast, musst Du die Files auch ebenso manuell wieder vom Server löschen. Das ist keine Deinstallations-Routine, wie Du sie von Windows-PCs her kennst (und selbst die arbeiten nicht immer restlos sauber, sondern hinterlassen Spuren - spätestens in der Registry und in Form leerer Ordner).
    11 Antwort(en) | 2923 mal aufgerufen
  • Avatar von Jaydee
    05.03.2019, 19:52
    Kannst Du denn ausschließen, dass auf dem neuen Server etwas gecached wird und dadurch evtl. veraltete Inhalte ausgegeben werden, die die diversen Änderungen überdecken? Auch auf sowas kann man ja schnell herein fallen. Ohne jeglichen Cache wird per PHP sofort 1:1 geparsed, dazu brauchst Du keine Debug-Scripte, um mögliche Fehler festzustellen. Die entstehen dann im Moment des Seitenaufrufs, sprich durch die Anfrage des Browsers. Die Files sorgen für die nötigen Datenbank-Queries, die...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von rowitech
    05.03.2019, 19:03
    Ja, hab das alles schon durch, eben alles nochmal probiert, aber alles gemacht ohne Erfolg. Gibt es vielleicht noch PHP-Skripte, die ich debuggen kann, so dass ich sehen kann, in welcher Form es aus der DB gelesen wird und dann auf die Website gepackt wird? Eigentlich ist das doch alles kein langer, komplizierter Prozess, oder? Leider steige ich bei den myriaden von PHP-Files nicht mehr durch...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von Jaydee
    05.03.2019, 16:46
    Jaydee hat auf das Thema Forum - Erweiterter Editor im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Das geht auch leider nicht. Diese Optionen werden als gemeinsamer Wert in der Datenbank abgelegt und greifen systemweit. Ein Style hat mit diesen Einstellungen nichts zu tun und ein User kann zumindest zwischen den 3 Editoren ohnehin in seinem Kontrollzentrum wählen, auch unabhängig vom Style. Für einzelne Foren geht es per Einstellung ebenfalls nicht. .Dort kannst Du aber einige der BB-Codes deaktivieren. Für alles andere bräuchte es also entweder ein passendes Add-on oder tiefere...
    8 Antwort(en) | 914 mal aufgerufen
  • Avatar von pipin
    05.03.2019, 13:58
    pipin hat auf das Thema Forum - Erweiterter Editor im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Ok, das war es. Danke. Stand auf Ja. Frage ist jetzt nur, das würde ich gerne nur in bestimmten Foren aktivieren bzw. in einem bestimmten Style. Ich finde aber den Trigger nicht, wo der auf dieses "Direkt ändern / Quick Edit" abfragt.
    8 Antwort(en) | 914 mal aufgerufen
  • Avatar von Jaydee
    05.03.2019, 13:31
    Jaydee hat auf das Thema Forum - Erweiterter Editor im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Klar, wie hast Du denn im ACP unter Einstellungen den Punkt Texte: Erstellen & Bearbeiten -> Direkt ändern' aktivieren stehen? Stelle den mal auf "Nein", dann hast Du es sofort. Unter "Texte: Editor" kannst Du dann auch wählen, welche Art des Editors dazu benutzt werden soll.
    8 Antwort(en) | 914 mal aufgerufen
  • Avatar von Jaydee
    05.03.2019, 13:16
    Unter anderem deshalb schrieb ich ja ganz oben das: (usw.) Die ist wirklich außen vor und nicht Teil des Problems, außer dass sie in dem Fall für zusätzliche Verwirrung sorgen kann. Das mit dem Apachen ist aber wirklich interessant. An sich ist ja eigentlich ISO-8859-1 ohnehin als eine Art "Standard" anzusehen. Habe aber gerade mal kurz geforscht und festgestellt, dass es tatsächlich etliche Erfahrungsberichte Deiner Art im Netz gibt und das Problem wohl häufiger auftaucht, als...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von Boothby
    05.03.2019, 13:07
    Das in der vhost: php_value default_charset ISO-8859-1 oder das in der php.ini: default_charset = "ISO-8859-1" ? Quelle
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von rowitech
    05.03.2019, 12:39
    Hmm, bald wäre es einfacher gewesen, einen Apache einfach neu zu schreiben :). Ich habe alles, wirklich alles auf ISO-8859-1 gestellt. Meine Shell ist wohl mit UTF-8 gestartet und zeigt damit für März auch nur noch "M�r" statt "Mär" an. Meinetwegen, ist ja nur die Shell. Locales hier: Was ich aber habe: Es scheint nicht an vBulletin zu liegen. Ich habe eine Textdatei geöffnet und mal ein paar Umlaute reingeworfen. Über den Apache komme sie ale Webseite verkorkst raus. Also liegt es...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von pipin
    05.03.2019, 12:26
    pipin hat auf das Thema Forum - Erweiterter Editor im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Muss mal ein wenig Leichenfledderei betreiben und diesen Thread hier ausgraben. Gibt es eigentlich irgendeine Möglichkeit, dass der erweiterte Editor auch direkt beim Editieren eines Postings aufgerufen wird? {vb:raw editorid}_adv Lässt sich ja imo nicht einfach in das postbit Template einfügen.
    8 Antwort(en) | 914 mal aufgerufen
  • Avatar von Jaydee
    04.03.2019, 20:46
    Stimmt, das deutet darauf hin, dass der Fehler erst beim Auslesen und der Darstellung entsteht. Das ist der Hauptunterschied und einer der Gründe, warum UTF-8 überhaupt geschaffen wurde. Nationale Zeichen/Umlaute plus Sonderzeichen, alles möglichst in einem gemeinsamen Zeichensatz. Und das wiederum macht diese 2-Byte Geschichte erforderlich und sinnvoll. "Kleinere" Zeichensätze mit mehr oder weniger "Standard-ASCII" kommen mit einem aus.
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von rowitech
    04.03.2019, 19:05
    Hatte ich geändert, müsste als PHP-File sofort wirksam sein, hab dennoch mal den apache neu gestartet => Keine Änderung. Da ist ne ganze Menge neu, also PHP-version ist nun 7 (statt die alte 4er), der alte Server ist echt alt. Auch die Debian-version ist 9 statt "uralt". Da wird ne ganze Menge anders sein. Dagegen spricht, dass ich bei selects in der Datenbank die Umlaute korrekt sehen kann. Das ist interessant, wusste ich noch nicht. Demnach bedeutet das aber doch, dass die Daten...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von olka
    04.03.2019, 13:12
    Danke für die Info und schnelle Hilfe, ich dachte mir schon etwas in der Art und hatte die Dateien zwischenzeitlich umbenannt. Allerdings hatte ich damit gerechnet, dass die Dateien mit der Deinstallation entfernt werden... :-o
    11 Antwort(en) | 2923 mal aufgerufen
  • Avatar von pogo
    04.03.2019, 12:20
    Entferne die Dateien redirector.php und local_links.php, die wohl zu Addons gehören, die du deinstalliert hast. Es könnten natürlich auch noch viel mehr alte, nicht mehr benötigte Dateien auf dem Server liegen. Um die zu löschen, müsstest du aber die Addons, sofern noch verfügbar, neu herunterladen und die zugehörigen Dateien ansehen. Auch hilft dir die Wartungsfunktion Dateiversionen anzeigen Dateien zu finden, die nicht zu vBulletin selbst gehören. Du musst beim Löschen dann aber...
    11 Antwort(en) | 2923 mal aufgerufen
  • Avatar von olka
    04.03.2019, 11:57
    Vielen Dank für die bisherige Hilfe. Ich habe jede Menge Add-ons, die ich beim Upgrade deaktiviert habe, mittlerweile deinstalliert. Ich vermute, dass seitdem und deshalb die folgenden Mails mit Datenbankfehlern bei mir eintrudeln. Ich habe bis jetzt noch nicht feststellen können wo und wie diese Datenbankfehler produziert werden. Das Forum läuft für meine Empfinden fehlerfrei. Vielleicht kann mir ja jemand helfen, wie ich die Fehler verhindern kann... Im Wesentlichen betrifft das...
    11 Antwort(en) | 2923 mal aufgerufen
  • Avatar von Jaydee
    04.03.2019, 11:55
    Ein weiterer "Klassiker" wäre auch noch, dass der Dump nach der Sicherung mit einem einfachen Texteditor geöffnet und damit wieder neu gespeichert wurde. Genau, das hatte mich neulich auch leicht irritiert, dass an einigen Stellen offenbar UTF-8 für die Anzeige erzwungen wird, an anderen Stellen aber genau umgekehrt. :confused: Macht für mich zunächst mal überhaupt keinen Sinn.
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von pogo
    04.03.2019, 11:01
    pogo hat auf das Thema Forum - Upgrade auf neuen Server und Umlautprobleme im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Deine Umlaute sehen zum Großteil so aus: ä Werden also durch zwei Zeichen dargestellt. à und ¤ Das passiert doch aber nur, wenn die Umlaute in UTF-8 in der Datenbank gespeichert sind, beim Anzeigen jedoch ISO-8859-1 erzwungen wird. UTF-8 speichert Umlaute mit zwei Bytes, daher auch in ISO-8859-1 die Anzeige von zwei Zeichen. Wenn in der Quelldatenbank latin1 genutzt wird, passiert also irgendwo auf dem Weg zur Zieldatenbank eine Konvertierung in UTF-8. Sei es beim Backup oder Import.
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von Jaydee
    02.03.2019, 18:11
    Dann frage ich mal anders: Kannst Du denn irgendwelche Unterschiede (außer der PHP Version) zwischen dem alten und neuen Server in der Konfiguration feststellen? Nach welchem "Schema" CHARSET und Collation auf einem Server - und dann auch innerhalb des MySQL - vererbt werden, wirst Du wahrscheinlich wissen, wenn Du eigene betreibst. Deshalb schenke ich mir das jetzt mal (Beachtung ist aber trotzdem wichtig!). Also um es zusammenzufassen, HTTP-Header besagt z.B. HTTP/1.1 (also ISO-8859-1),...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von rowitech
    02.03.2019, 17:34
    Ich habe sogar die Binärdateien der DB mal kopiert. Ebenso rausselected und wieder importiert (ohne große externe Hilfsmittel). Irgendwie sieht die neue DB perfekt aus, alles klappt super, alles sieht richtig aus.. Was sollte da noch anders sein? Alle Einträge absolut tutti. Ich bekomme graue Haare.. MariaDB > select charset from language limit 50; +------------+ | charset | +------------+ | ISO-8859-1 | | ISO-8859-1 |
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von pogo
    02.03.2019, 15:46
    pogo hat auf das Thema Forum - Upgrade auf neuen Server und Umlautprobleme im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Du hast auf dem alten Server geprüft, mit welchem Zeichensatz und Kollation die dortige Datenbank betrieben wird und dann auf dem neuen Server eine neue Datenbank mit identischen Werten erstellt? Beim Backup mit mysqldump und beim Import mit mysql hast du den Zeichensatz als Parameter angegeben? z.B. --default-character-set=latin1 Wenn nicht, versuch es mal so.
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von Jaydee
    02.03.2019, 11:49
    Entscheidend ist nicht nur der Apache und auch die Shell lass erst mal außen vor. Entscheidend ist u.a., ob es einen CHARSET Unterschied zwischen dem Datenbank-Server des alten und des neuen Servers gibt - und mit welchem das Backup dann erstellt (und wieder eingespielt) wurde. Allein das reicht schon für totales Chaos aus, wenn es Abweichungen gibt. Auch die Sprachdaten wären davon betroffen, da sie ebenfalls in der DB liegen. Schau z.B. mal (unabhängig von der gesamten MySQL-Einstellung)...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von rowitech
    02.03.2019, 11:27
    Vielen Dank für die Antworten. Naja, das Forum auf ein anderes umzustellen, weil der Zeichensatz verrutscht ist, wäre mir zu viel. Aber mir ist natürlich bewusst, dass das irgendwann ein Ende hat (das Forum wird dieses Jahr 20 Jahre alt!). In der Datenbank kann ich alles auf der Konsole sauber auslesen, d.h. in der Shell werden bei einem Select die Umlaute richtig dargestellt. Damit ist es auf Shell-Ebene schonmal ok, würde ich sagen. Nächste Ebene ist der Apache, der im header ISO-8859-1...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von Jaydee
    02.03.2019, 11:04
    Hallo Rolf, zum konkreten Problem: Der Server mit der "www2." Domain läuft offenbar mit dem Charset UTF-8, Dein Forum dort ist aber nach wie vor auf ISO-8859-1 eingestellt. In dem Fall betrifft es sogar beide Bereiche, sowohl die Software selbst (allem voran das Sprachpaket) als auch die eigentlichen, dynamischen Inhalte z.B. im CMS. Wenn es Dein eigener Server ist, sollte eine Anpassung an die "alte" Umgebung des bisherigen Servers ja kein Problem darstellen. Das wäre der einfachste...
    17 Antwort(en) | 1676 mal aufgerufen
  • Avatar von Boothby
    02.03.2019, 06:32
    Sicherlich gibt es technische Lösungen, und nach dieser muß die nächste her und danach wieder die nächste, weil vBulletin einfach hoffnungslos veraltet ist und niemand sich rarum kümmert, was zwangsläufig ist, wenn eine Software EOL deklariert wurde. Wechsel die Software! Welche für dich passend ist mußt du selbst für dich entscheiden und auf deine Anforderungen abstimmen.
    17 Antwort(en) | 1676 mal aufgerufen
Weitere Aktivitäten