Aktivitäten

Aktivitäten filtern
Sortieren nach Zeit Anzeigen
Aktualität Aktualität Beliebtheit Beliebtheit Alle Alle Letzte 24 Stunden Letzte 24 Stunden Letzte Woche Letzte Woche Letzter Monat Letzter Monat Alle Alle Bilder Bilder Forum Foren Artikel Artikel Blog Blogs Gruppen Gruppen
  • Avatar von Jaydee
    Gestern, 11:28
    Jaydee hat auf das Thema Forum - Thema Bewertungsprobleme bei USER im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Wobei das allerdings nach meinem Verständnis noch nicht erklären würde, warum es (beim selben Benutzer) vom einen Rechner aus ohne Fehlermeldung funktioniert, vom nächsten aus dem selben Netzwerk heraus (also selbe IP, selber Router etc.) aber nicht. Daher tippe ich ganz stark auf ein jeweils lokales Problem bei der jeweiligen Rechner-Konfiguration. Auch das nicht geparste <em> TAG in der Meldung finde ich irgendwie seltsam. Was aber natürlich wiederum kaum Client-seitig hervorgerufen...
    9 Antwort(en) | 392 mal aufgerufen
  • Avatar von Boothby
    Gestern, 11:15
    Boothby hat auf das Thema Forum - Thema Bewertungsprobleme bei USER im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Schau doch bitte nach, ob für die betreffenden Nutzer korrekte IP's eingetragen wurden.
    9 Antwort(en) | 392 mal aufgerufen
  • Avatar von Pirates
    20.08.2017, 11:59
    Pirates hat auf das Thema Forum - Thema Bewertungsprobleme bei USER im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Hallo Jaydee Ja beide sind am Gleichen Netzwerk Das mit der Firewall-Einstellungen da habe ich natürlich noch nicht nachgeschaut. Muss auch ehrlich gestehen das ich noch nicht genau weis wie und wo ich da genau schauen soll, aber ich werde es mal versuchen zu suchen und zu schauen ob ich da was finde.
    9 Antwort(en) | 392 mal aufgerufen
  • Avatar von Jaydee
    20.08.2017, 11:35
    Jaydee hat auf das Thema Forum - Thema Bewertungsprobleme bei USER im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Das ist tatsächlich interessant. Der Laptop Deiner Frau hängt vermutlich im selben Netzwerk wie Deiner, also auch ohne Proxy dazwischen usw.? Und das Problem tritt auch nicht nur temporär auf, sondern der jeweilige Rechner verhält sich immer gleich (also bei A geht es immer und bei B geht es nie)? Dann könnte man es ja lokal eingrenzen, also evtl. mal die Firewall-Einstellungen, Browser usw. vergleichen, ob da irgendetwas geblockt wird. Insgesamt klingt das ja zunächst ziemlich unlogisch.
    9 Antwort(en) | 392 mal aufgerufen
  • Avatar von Pirates
    20.08.2017, 09:58
    Pirates hat auf das Thema Forum - Thema Bewertungsprobleme bei USER im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Sorry das ich mich so Spät zu eure Poste Melde, ich war ein Paar Tage weg. Ich habe festgestellt dass ich auf meinem PC als Admin und als USER Bewertung abgeben kann. Aber auf dem Laptop meiner Frau kommt auch dieselbe Meldung wie es mir ein User aus meinem Forum Geschrieben hatte.
    9 Antwort(en) | 392 mal aufgerufen
  • Avatar von Boothby
    19.08.2017, 16:54
    Boothby hat auf das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung geantwortet.
    Jo sollte so funktionieren. Der Callback ist eh überflüssig. Beim obigen Beispiel im übrigen auch, denke ich.
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von Masterix
    19.08.2017, 08:07
    Masterix hat auf das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung geantwortet.
    Hmmm... Laut Pluginsystem -> Einstiegspunkt (Hook) ist dieses Addon das einzige, das diesen forumhome_start Hook verwendet, auf den die Fehlermeldung (index.php(67) ==> $hook = vBulletinHook::fetch_hook('forumhome_start')) ? eval($hook) : false; verweist. :confused: Nachtrag.... Könnte auch ein Bug in php 7.x sein? Nachtrag 2. Auch ein fast blindes Huhn findet mal ein Korn ;)
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von Boothby
    19.08.2017, 07:19
    Boothby hat auf das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung geantwortet.
    Ich denke mal an anderer Stelle, evtl anderes Add-on was den gleichen Hook verwendet.
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von Masterix
    19.08.2017, 07:11
    Masterix hat auf das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung geantwortet.
    Ungetestet, aber funktioniert exakt wie vorstehend - mit nur einer neuen Warnung. ;) Got error 'PHP message: PHP Warning: preg_replace_callback(): The /e modifier is no longer supported, use preg_replace_callback instead Diese Fehlermeldungen... Wo ist da jetzt bitte ein /e modifier zu finden. Aber erstmal einen herzlichen Dank für die Hilfe bisher. Nachtrag, hab Stripslashes durch explode ausgetauscht.
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von Boothby
    19.08.2017, 04:47
    Boothby hat auf das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung geantwortet.
    Moin moin. Nimm mal statt preg_split lieber explode. http://php.net/manual/de/function.explode.php Zum 2. Ausdruck: ich sehe eine Lösung bin aber nur mit Handy unterwegs. Hoffe es klappt $fb2p = preg_replace_callback( '#(<tr>*?<td class=\\\\")alt2(.*?<td class=\\\\")alt1#eis', function($treffer){$tr1=$treffer;$tr2=$treffer; return "stripslashes('$tr1').((++\$_xx%2)?'alt1':'alt2').stripslashes('$tr2').((\$_xx%2)?'alt1':'alt2')";},
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von Jaydee
    18.08.2017, 14:05
    Möglicherweise erzeugte aber genau das von mir im Zitat Fett-Markierte das Problem: Dein Link enthält eine Portnummer (was soweit nichts Ungewöhnliches ist) und Port 443 ist für SSL/TLS (also HTTPS) zuständig. Im URL hast Du da aber "nur" HTTP stehen. Vielleicht kam es da zu Konflikten? Der Port wird ja dann praktisch "erzwungen". Und ohne Zertifikat (auf dem entspr. Server) funktioniert das dann sowieso nicht. Im 2. Beispiel (Chrome) hattest Du es dann korrekt und das würde auch...
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von Masterix
    18.08.2017, 08:38
    Masterix hat auf das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung geantwortet.
    Ja, ich sah hier den Wald vor lauter Bäumen nimmer. ;) Der wirkliche Fehler scheint eine "Splitfunktion zu sein. ErrorTrace: Call to undefined function split() in ..../index.php(596) : eval()'d code on line 1 ($hook = vBulletinHook::fetch_hook('forumhome_complete')) ? eval($hook) : false; Fehlerhafte Zeile: if ($vbulletin->options'cyb_visitorslastx_enable'] AND !is_member_of($vbulletin->userinfo, split(',', $vbulletin->options'cyb_visitorslastx_exclgroups'])))
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von Boothby
    18.08.2017, 07:31
    Boothby hat auf das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung geantwortet.
    Welche vB-Version hast du? Falls du noch die angegebene 3.8.11 nutzt, dann ist obiges Konstrukt der vB-Standard um Templatecode auszuführen. Und das geschätzte 3845 mal im Code (die Zahl ist natürlich Quatsch ;)). Hinzu kommen noch alle Plugins, die ebenfalls auf eval setzen. Falls eval dir Probleme bereitet, dürfte dort gar nichts mehr laufen und nicht nur die von dir zitierte Codezeile. Es spricht nichts gegen einen Einsatz von eval unter PHP 7. Bekommst du irgendwelche Fehlermeldungen?
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von Masterix
    18.08.2017, 06:55
    Masterix hat das Thema Ersatz für "eval" php 7.1.18 im Forum PHP-Programmierung erstellt.
    Ich nutze ein Plugin von "Cyb" das die Onlineanzeige anpasst. Hierin wird im Code Folgendes verwendet: ... eval('$cyb_vilxh = "' . fetch_template('cyb_lastxhoursvisitors') . '";'); ... Wie kann ich dies eval ersetzen. Ich bin nicht so firm in Sachen PHP und die Recherche im Netz dazu verwirrt nur mehr als dass sie hilft.
    7 Antwort(en) | 312 mal aufgerufen
  • Avatar von oliveer
    17.08.2017, 19:36
    Irgendwie blick ich jetzt garnicht mehr durch ... Ich hab es endlich geschafft, aber irgendwie ist die Lösung sehr dubios. Download der Datei vbulletin 3.8.11 von vbulletin.com, entpackt und die Daten von der neu erstellten Datenbank entsprechend eingetragen ... Step 3 Creating datastore table Step 5 Inserting default data into datastore
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von Jaydee
    17.08.2017, 17:28
    Jaydee hat auf das Thema Allgemein - Aktionen hängen immer eins hinter her im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Dieses Verhalten und verzögerte "Refresh" ist aber eigentlich normal, das sind auch nur wenige Sekunden (nach dem letzten Click im Forum oder ACP) und war bereits in den ganz alten 3er versionen so, seit es diese Funktion gibt. Ich kenne das überhaupt nicht anders und normal stört das doch auch nicht weiter. Ein "gröberer" Fehler steckt aber tatsächlich drin: Es werden nicht alle User als solche angezeigt, die Tapatalk nutzen und darüber gerade eingeloggt sind. Wenn beispielsweise gerade...
    3 Antwort(en) | 201 mal aufgerufen
  • Avatar von Jaydee
    17.08.2017, 17:12
    Was Du beschreibst als Vorgang, ist schon verständlich (auch wenn ich den Sinn nicht ganz verstehe, wenn Du bereits ein Forum hattest und das später wieder nutzen möchtest). Nur macht Dein erster Beitrag dann keinen Sinn, denn bei einer Erst-Installation exisitiert (natürlich) noch überhaupt kein vBulletin Datastore. Die Meldung ist also berechtigt - nur ebenso unsinnig, sie auszugeben. Denn die Tabelle wird natürlich erst noch angelgt, kann also auch nicht bereits existieren. Derartige...
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von Thunder_one
    17.08.2017, 15:58
    Thunder_one hat auf das Thema Allgemein - Passwort ist veraltet ausschalten ? im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Danke euch beiden.
    4 Antwort(en) | 159 mal aufgerufen
  • Avatar von oliveer
    17.08.2017, 14:45
    Das hast du irgendwie falsch verstanden .... Download der Datei von vbulletin.com, Änderung der config.php und upload und dann ganz normal den Installer gestartet ....
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von pogo
    17.08.2017, 14:42
    pogo hat auf das Thema Allgemein - Passwort ist veraltet ausschalten ? im Forum vBulletin 4 Fragen und Probleme geantwortet.
    In den Einstellungen der Benutzergruppe findest du Kennwortgültigkeit. Nicht Foren-Rechte oder so.
    4 Antwort(en) | 159 mal aufgerufen
  • Avatar von pogo
    17.08.2017, 14:34
    Darf nicht. Ich kann mir auch nur vorstellen, dass in der config.php ein anderes Präfix für die Datenbank Tabellen angegeben ist, als in der Datenbank tatsächlich genutzt wird.
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von Thunder_one
    17.08.2017, 13:50
    Thunder_one hat auf das Thema Allgemein - Passwort ist veraltet ausschalten ? im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Hmmm. Finde dort jetzt aber nichts.
    4 Antwort(en) | 159 mal aufgerufen
  • Avatar von oliveer
    17.08.2017, 12:56
    Seltsam .... Aber bei einer jungfräulichen Installation darf es doch keine Fehler werfen .... Bei meinem alten Hoster hat es geklappt
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von pogo
    17.08.2017, 12:47
    So funktioniert das nicht. Du musst nur das Backup einspielen. Also Dateien kopieren und Datenbank-Backup einspielen.
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von oliveer
    17.08.2017, 12:20
    Erst einmal möchte ich das Forum neu installieren und dann später das Backup meines alten Forums einspielen, aber soweit komme ich nicht, da ich ja die Fehlermeldung erhalte. Also bisher nur die jungfräuliche Installation ...
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von pogo
    17.08.2017, 12:15
    Du hast also den Hoster gewechselt und willst dort ein komplett neues Forum aufbauen. Das alte soll nicht importiert werden oder so? Oder was genau hast du vor?
    9 Antwort(en) | 243 mal aufgerufen
  • Avatar von Boothby
    17.08.2017, 11:12
    Boothby hat auf das Thema Allgemein - Passwort ist veraltet ausschalten ? im Forum vBulletin 4 Fragen und Probleme geantwortet.
    Sollte unter den Benutzergruppenberechtigungen zu finden sein. Dort den Wert für die betreffenden BG auf Null stellen.
    4 Antwort(en) | 159 mal aufgerufen
  • Avatar von Thunder_one
    17.08.2017, 07:36
    Hi Ich bekan heute auf meinem Board die meldung das mein Passwort veraltet ist. Das es 100 Tage schon her ist. Wie bzw wo kann man das bitte deaktivieren das diese Anfrage nicht mehr kommt? Vielen dank.
    4 Antwort(en) | 159 mal aufgerufen
  • Avatar von Masterix
    17.08.2017, 07:34
    Erledigt, einfach A durch B ersetzt.... Klappt :)
    5 Antwort(en) | 442 mal aufgerufen
  • Avatar von Thunder_one
    17.08.2017, 07:34
    Thunder_one hat auf das Thema Allgemein - Aktionen hängen immer eins hinter her im Forum vBulletin 4 Fragen und Probleme geantwortet.
    ok super danke schon mal.
    3 Antwort(en) | 201 mal aufgerufen
Weitere Aktivitäten